Si sabes leer y escribir, sabes programar!

Foro

[Resuelto] CMake Error at CMakeLists.txt:1 (CMAKE_MINIMUM_REQUIRED):CMake 3.4.3 or higher is required. You are running version 3.0.2  

  RSS

Robin
Eminent Member Admin
Registrado:hace 6 meses 
Respuestas: 47
24/07/2017 5:54 pm  

Con esto puedes resolver ese problema

Verificar la version

cmake --version

desinstalar

sudo apt remove cmake

Cargar la ultima version 3.9.0

wget  https://cmake.org/files/v3.9/cmake-3.9.0.tar.gz 

Descomprimir

tar xvf cmake-3.9.0.tar.gz
cd cmake-3.9.0
./configure
make
make install
ln -s /usr/local/bin/cmake /usr/bin/cmake

 

Ahora todo en un solo codigo

cd ~
sudo apt remove cmake -y
wget https://cmake.org/files/v3.9/cmake-3.9.0.tar.gz
tar xvf cmake-3.9.0.tar.gz
cd cmake-3.9.0
./configure
make
make install
ln -s /usr/local/bin/cmake /usr/bin/cmake

 

Editado:hace 3 semanas 

ResponderCitar
  
Trabajando

7,417 total views, 1 views today